summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-02-07 20:25:12 +0100
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-02-07 20:25:54 +0100
commit771e1e7521fddc1f36f966c4b418f69c13c1aeea (patch)
tree306d7e114d8681ea92d773952a1bf3429e679c1f /gnu
parentbab3110d44f454e5bed0a3fc10c5d4a8b33cc220 (diff)
downloadguix-771e1e7521fddc1f36f966c4b418f69c13c1aeea.tar.gz
gnu: python2-renpy: Update to 7.4.2.
* gnu/packages/game-development.scm (python2-renpy): Update to 7.4.2.
[native-inputs]: Add gcc-8.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 1ddd0e531f..92c3da92ab 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -63,6 +63,7 @@
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
   #:use-module (gnu packages dbm)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -1141,13 +1142,13 @@ developed mainly for Ren'py.")
 (define-public python2-renpy
   (package
     (name "python2-renpy")
-    (version "7.4.0")
+    (version "7.4.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.renpy.org/dl/" version
                            "/renpy-" version "-source.tar.bz2"))
-       (sha256 (base32 "0av3mbh54xh6i3rvf60x5hbsjcfpzgia2j958mhyc5826zjxzfpg"))
+       (sha256 (base32 "1mlrq9q3r36izyskq674qhp8s32iirvvfb4r8z6hi26189aaydsw"))
        (modules '((guix build utils)))
        (patches
         (search-patches
@@ -1224,7 +1225,8 @@ developed mainly for Ren'py.")
      `(("python2-future" ,python2-future)
        ("python2-pygame" ,python2-pygame-sdl2)))
     (native-inputs
-     `(("python2-cython" ,python2-cython)
+     `(("gcc" ,gcc-8) ; for const variables as initializer elements
+       ("python2-cython" ,python2-cython)
        ("xdg-utils" ,xdg-utils)))
     (home-page "https://www.renpy.org/")
     (synopsis "Ren'py python module")