summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:17:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:49 +0200
commit7753737fabec01cd511bc6ad3a03c61aec86539b (patch)
tree72b8848f97b3cfa266b6ea10629baa0acdbc968f /gnu
parent3dd798a1397174a72439388a44b5e797469fa0ef (diff)
downloadguix-7753737fabec01cd511bc6ad3a03c61aec86539b.tar.gz
gnu: Add texlive-mugsthesis.
* gnu/packages/tex.scm (texlive-mugsthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f473dfd715..b8b10d7486 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -21965,6 +21965,28 @@ printing.")
 guidelines for submissions to the German Mensch und Computer conference.")
     (license license:lppl1.3+)))
 
+(define-public texlive-mugsthesis
+  (package
+    (name "texlive-mugsthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/mugsthesis/"
+                   "source/latex/mugsthesis/"
+                   "tex/latex/mugsthesis/")
+             (base32
+              "0xf3zjwx6k2dg1hrz4nw6shn6xk3lvmjprg3psfrh3z38r1sp9nh")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/mugsthesis")
+    (synopsis
+     "Thesis class complying with Marquette University Graduate School
+requirements")
+    (description
+     "The bundle offers a thesis class, based on @code{memoir}, that complies
+with Marquette University Graduate School requirements.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-multibib
   (package
     (name "texlive-multibib")