summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-17 22:06:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:44 -0400
commit7800103c8189cde3eebdc1c083fb104ced63ba59 (patch)
treeb441a510c51bfdb9aae3fdc55a92aef755633799 /gnu
parent253f51dcbb110644842becc2fb91adf599dc8d83 (diff)
downloadguix-7800103c8189cde3eebdc1c083fb104ced63ba59.tar.gz
gnu: ruby-shoulda-matchers: Honor #:tests?.
* gnu/packages/ruby.scm (ruby-shoulda-matchers)
[arguments]: Honor #:tests? in check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0c7dc39d50..faf3dafdda 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10121,10 +10121,11 @@ names.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             ;; Do not run tests to avoid circular dependence with rails.  Instead
-             ;; just import the library to test.
-             (invoke "ruby" "-Ilib" "-r" "shoulda-matchers"))))))
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               ;; Do not run tests to avoid circular dependence with rails.  Instead
+               ;; just import the library to test.
+               (invoke "ruby" "-Ilib" "-r" "shoulda-matchers")))))))
     (propagated-inputs
      (list ruby-activesupport))
     (synopsis "Collection of testing matchers extracted from Shoulda")