summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandr Vityazev <avityazev@posteo.org>2021-08-30 21:42:43 +0000
committerLudovic Courtès <ludo@gnu.org>2021-09-07 15:59:35 +0200
commit7865973ef73ca6f634d68b20e18c28a5ea407fbe (patch)
treea9d2a569ac3c922c410c1b6aa189ad829db97d5c /gnu
parente8a67f0fc4f7274d2447ac247df60b69d98e1b4e (diff)
downloadguix-7865973ef73ca6f634d68b20e18c28a5ea407fbe.tar.gz
emacs-org-roam: Add new phase after unpack.
* gnu/packages/emacs-xyz.scm (emacs-org-roam)[arguments]<phases>:
After the unpack phase add a move-source-files phase to include
the org-roam extensions to the package.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 88368d05d6..88040ded11 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -28245,6 +28245,15 @@ snippets for Emacs.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         ;; Move the extensions source files to the top level, which is included in
+         ;; the EMACSLOADPATH.
+         (add-after 'unpack 'move-source-files
+           (lambda _
+             (let ((el-files (find-files "./extensions" ".*\\.el$")))
+               (for-each (lambda (f)
+                           (rename-file f (basename f)))
+                         el-files))
+             #t))
          (add-after 'install 'install-image
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))