summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-14 17:16:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-14 17:19:06 +0100
commit7885b5be9bdedde417e46eb85e55b8ab98dd25df (patch)
treefd49f1bf0989ce2ba375061289a974753499ecf9 /gnu
parent6cf6f423340f060e523c007205b691ec68120f50 (diff)
downloadguix-7885b5be9bdedde417e46eb85e55b8ab98dd25df.tar.gz
gnu: 389-ds-base: Drop input labels.
* gnu/packages/openldap.scm (389-ds-base)[inputs]: Drop labels.
[native-inputs]: Drop labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/openldap.scm69
1 files changed, 34 insertions, 35 deletions
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index 78f96e6190..cdacc99fa1 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -357,42 +357,41 @@ servers from Python programs.")
                            "/bin/ds-logpipe.py"
                            "/bin/ds-replcheck"))))))))
     (inputs
-     `(("bdb" ,bdb)
-       ("cracklib" ,cracklib)
-       ("cyrus-sasl" ,cyrus-sasl)
-       ("gnutls" ,gnutls)
-       ("httpd" ,httpd)
-       ("icu4c" ,icu4c)
-       ("iproute" ,iproute)
-       ("libevent" ,libevent)
-       ("libselinux" ,libselinux)
-       ("linux-pam" ,linux-pam)
-       ("mit-krb5" ,mit-krb5)
-       ("net-snmp" ,net-snmp)
-       ("nspr" ,nspr)
-       ("nss" ,nss)
-       ("nss:bin" ,nss "bin")           ; for certutil
-       ("openldap" ,openldap)
-       ("openssl" ,openssl)             ; #included by net-snmp
-       ("pcre" ,pcre)
-       ("perl" ,perl)
-       ("python" ,python)
-       ("python-pyasn1" ,python-pyasn1)
-       ("python-pyasn1-modules" ,python-pyasn1-modules)
-       ("python-pytest" ,python-pytest)
-       ("python-dateutil" ,python-dateutil)
-       ("python-six" ,python-six)
-       ("python-argcomplete" ,python-argcomplete)
-       ("python-argparse-manpage" ,python-argparse-manpage)
-       ("python-ldap" ,python-ldap)))
+     (list bdb
+           cracklib
+           cyrus-sasl
+           gnutls
+           httpd
+           icu4c
+           iproute
+           libevent
+           libselinux
+           linux-pam
+           mit-krb5
+           net-snmp
+           nspr
+           nss
+           (list nss "bin")             ; for certutil
+           openldap
+           openssl                      ; #included by net-snmp
+           pcre
+           python
+           python-pyasn1
+           python-pyasn1-modules
+           python-pytest
+           python-dateutil
+           python-six
+           python-argcomplete
+           python-argparse-manpage
+           python-ldap))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("doxygen" ,doxygen)
-       ("gettext" ,gettext-minimal)
-       ("libtool" ,libtool)
-       ("rsync" ,rsync)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf
+           automake
+           doxygen
+           gettext-minimal
+           libtool
+           rsync
+           pkg-config))
     (home-page "https://directory.fedoraproject.org")
     (synopsis "Enterprise-class LDAP server")
     (description "389ds is an enterprise-class LDAP server.  It is hardened by