summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-10 02:47:15 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 00:04:36 +0200
commit78f46e65bd1433009bd974b9d150e5675e5a7201 (patch)
tree1d078ba2c7896e908ce03e7bdf9a40c8e36f5810 /gnu
parentb84ef9e2246024ca0fbec34d0fb0cc39901f674f (diff)
downloadguix-78f46e65bd1433009bd974b9d150e5675e5a7201.tar.gz
gnu: Add python-pkginfo.
* gnu/packages/python.scm (python-pkginfo, python2-pkginfo): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 98fa998042..952af29052 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -16381,3 +16381,33 @@ design and layout.")
 
 (define-public python2-tqdm
   (package-with-python2 python-tqdm))
+
+(define-public python-pkginfo
+  (package
+    (name "python-pkginfo")
+    (version "1.4.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "pkginfo" version))
+        (sha256
+          (base32
+            "17pqjfpq3c6xzdmk8pski6jcjgjv78q00zjf2bgzb668pzm6l6mv"))))
+    (build-system python-build-system)
+    (arguments
+     ;; The tests are broken upstream.
+     '(#:tests? #f))
+    (home-page
+      "https://code.launchpad.net/~tseaver/pkginfo/trunk")
+    (synopsis
+      "Query metadatdata from sdists, bdists, and installed packages")
+    (description
+      "API to query the distutils metadata written in @file{PKG-INFO} inside a
+source distriubtion (an sdist) or a binary distribution (e.g., created by
+running bdist_egg).  It can also query the EGG-INFO directory of an installed
+distribution, and the *.egg-info stored in a \"development checkout\" (e.g,
+created by running @code{python setup.py develop}).")
+    (license license:expat)))
+
+(define-public python2-pkginfo
+  (package-with-python2 python-pkginfo))