summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-27 00:12:06 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 17:24:27 +0200
commit79d5a18116d597df9e3d6b607164947d3aed6c2f (patch)
tree22024fdbbd2f1b5a3f89049ecebbe85065d210c4 /gnu
parentdafcf2fcc015e66a7924597193f0f012dad1d0d6 (diff)
downloadguix-79d5a18116d597df9e3d6b607164947d3aed6c2f.tar.gz
gnu: Add go-github-com-songmu-gitconfig.
* gnu/packages/golang.scm (go-github-com-songmu-gitconfig): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 12529439b3..60535e07bd 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6542,3 +6542,29 @@ modifying them.")
 compressed streams in Go.")
     (home-page "https://github.com/ulikunitz/xz")
     (license license:bsd-3)))
+
+(define-public go-github-com-songmu-gitconfig
+  (package
+    (name "go-github-com-songmu-gitconfig")
+    (version "0.1.0")
+    (home-page "https://github.com/songmu/gitconfig")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/Songmu/gitconfig"
+       ;; Package's tests appear to be hardcoded to the author's gitconfig
+       ;; and require network access.
+       #:tests? #f))
+    (propagated-inputs
+     `(("go-github-com-goccy-yaml" ,go-github-com-goccy-yaml)))
+    (synopsis "Go library to get configuration values from gitconfig")
+    (description "@{gitconfig} is a package to get configuration values from gitconfig.")
+    (license license:expat)))