summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-16 11:03:10 +0200
committerDavid Thompson <dthompson2@worcester.edu>2015-09-19 08:51:27 -0400
commit7ac4610f7e00a08e3d05eb49b488043b3f0005a7 (patch)
tree092e59ab3ee8cecf6513a6ffdb0b92814f25fb0a /gnu
parent8528365b0ebd7f7f4cb532165aa509b80e87c236 (diff)
downloadguix-7ac4610f7e00a08e3d05eb49b488043b3f0005a7.tar.gz
gnu: Add ruby-shindo.
* gnu/packages/ruby.scm (ruby-shindo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d73e854774..d80d3aa424 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -646,6 +646,35 @@ standard output stream.")
     (home-page "http://github.com/geemus/formatador")
     (license license:expat)))
 
+(define-public ruby-shindo
+  (package
+    (name "ruby-shindo")
+    (version "0.3.8")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "shindo" version))
+              (sha256
+               (base32
+                "0s8v1jbz8i0jh92f2fgxb3p51l1azrpkc8nv4mhrqy4vndpvd7wq"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:test-target "shindo_tests"
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-tests
+          (lambda _
+            (substitute* "Rakefile"
+              (("system \"shindo") "system \"./bin/shindo")
+              ;; This test doesn't work, so we disable it.
+              (("fail \"The build_error test should fail") "#"))
+            #t)))))
+    (propagated-inputs
+     `(("ruby-formatador" ,ruby-formatador)))
+    (synopsis "Simple depth first Ruby testing")
+    (description "Shindo is a simple depth first testing library for Ruby.")
+    (home-page "https://github.com/geemus/shindo")
+    (license license:expat)))
+
 (define-public ruby-useragent
   (package
     (name "ruby-useragent")