summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-04-24 08:14:32 -0300
committerVinicius Monego <monego@posteo.net>2023-05-14 11:10:24 -0300
commit7b00b155d8f474d493a22ff7cccbeec311b9bbc8 (patch)
tree3cf874c52cef1496a3168cca25ff238404354550 /gnu
parentc5ebf6ff974057daa3e078f806df9a151440fecd (diff)
downloadguix-7b00b155d8f474d493a22ff7cccbeec311b9bbc8.tar.gz
gnu: Add morss.
* gnu/packages/syndication.scm (morss): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syndication.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index a53b1e2f6d..68c7fce26c 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2017, 2019-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020, 2023 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Luis Felipe López Acevedo <luis.felipe.la@protonmail.com>
 ;;; Copyright © 2022 Liliana Marie Prikler <liliana.prikler@gmail.com>
@@ -509,6 +509,34 @@ a simple interface that makes it easy to organize and browse feeds.")
     (license (list license:expat
                    license:gpl3+))))    ; tuir/packages/praw
 
+(define-public morss
+  (package
+    (name "morss")
+    (version "20221213.2216")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "morss" version))
+              (sha256
+               (base32
+                "1mvxxhzmraxjnw0vz60zkl4d8xp7lw0fs0z537zfhmj1lj9ap4cp"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests are not available in the PyPI release and the Git release
+     ;; is lagging behind.  Additionally, tests use the network.
+     (list #:tests? #f
+           ;; Sanity check fails to find the module 'bs4', but it's available
+           ;; in the python-beautifulsoup4 dependency.
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'sanity-check))))
+    (propagated-inputs (list python-beautifulsoup4 python-chardet
+                             python-dateutil python-lxml))
+    (home-page "https://morss.it/")
+    (synopsis "Get full-text RSS feeds")
+    (description "Morss' goal is to get full-text RSS feeds out of striped
+RSS feeds, commonly available on the internet.  It also makes it possible
+to create RSS feeds for websites that don't provide any.")
+    (license license:agpl3+)))
+
 (define-public syndication-domination
   (let ((revision "1")
         (commit "75920321062d682437f3fb0319dad227d8b18f6c"))