summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-07-18 13:24:12 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-18 13:28:11 +0200
commit7bbe61f8fffb0f21e9a75c7fb8e134d7dbaa9ced (patch)
treeea17dcbf110a549d38a28964075b5cfc5e2d0e18 /gnu
parentb998b19e5189b67239c4058ecc31dd054083fe75 (diff)
downloadguix-7bbe61f8fffb0f21e9a75c7fb8e134d7dbaa9ced.tar.gz
gnu: java-hamcrest-library: Fix race condition.
* gnu/packages/java.scm (java-hamcrest-library)[arguments]: Fix
build.xml in the same way it is fixed in java-hamcrest-all to prevent a
race condition.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d42b537ae2..424c24b75f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3796,6 +3796,13 @@ testing frameworks, mocking libraries and UI validation rules.")
       ((#:build-target _) "library")
       ((#:phases phases)
        `(modify-phases ,phases
+          (add-after 'unpack 'patch-classpath-for-integration
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* "build.xml"
+                (("build/hamcrest-core-\\$\\{version\\}\\.jar")
+                 (car (find-files (assoc-ref inputs "java-hamcrest-core")
+                                  "jar$"))))
+              #t))
           (replace 'create-pom
             (lambda _
              (substitute* "pom/hamcrest-library.pom"