summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-09-02 18:15:42 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-02 18:16:51 +0200
commit7c1b82f256e445214c64182405649b4b3ff2d1de (patch)
treec6f31aba7ba95b31c97963fffabfd4420aab476f /gnu
parent2c5c04eb2be09bf5e1c504c4be64fea5ebb3f40c (diff)
downloadguix-7c1b82f256e445214c64182405649b4b3ff2d1de.tar.gz
gnu: openexr@2: Skip failing test on i686.
* gnu/packages/graphics.scm (openexr-2)[arguments]: In
'disable-broken-test', skip 'testCompression' as well.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index d9e0b5b859..3f6e7d64a5 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1181,13 +1181,15 @@ with strong support for multi-part, multi-channel use cases.")
              #t))
          ,@(if (not (target-64bit?))
                `((add-after 'change-directory 'disable-broken-test
-                   ;; This test fails on i686. Upstream developers suggest that
-                   ;; this test is broken on i686 and can be safely disabled:
-                   ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
                    (lambda _
                      (substitute* "IlmImfTest/main.cpp"
-                       ((".*testOptimizedInterleavePatterns.*") ""))
-                     #t)))
+                       ;; This test fails on i686. Upstream developers suggest
+                       ;; that this test is broken on i686 and can be safely
+                       ;; disabled:
+                       ;; https://github.com/openexr/openexr/issues/67#issuecomment-21169748
+                       ((".*testOptimizedInterleavePatterns.*") "")
+                       ;; This one fails similarly on i686.
+                       ((".*testCompression.*") "")))))
                '()))))
     (native-inputs
      (list pkg-config))