summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-03-09 16:36:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:21 +0300
commit7c89fc22307cdb1240be132493caf8b1ea26165c (patch)
tree1381ab9bd4347093e885f61e72009407692ac4cd /gnu
parent1f0b0f8f752444c80c66f704bcd91985d9c85a85 (diff)
downloadguix-7c89fc22307cdb1240be132493caf8b1ea26165c.tar.gz
gnu: Add rust-ron-0.7.
* gnu/packages/crates-io.scm (rust-ron-0.7): New variable.
(rust-ron-0.6): Inherit from rust-ron-0.7.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 29 insertions, 6 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 6f17c6c00e..3d33415d6f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -49337,8 +49337,36 @@ responses, and headers for the Rocket web framework.")
 network services using futures.")
     (license license:expat)))
 
+(define-public rust-ron-0.7
+  (package
+    (name "rust-ron")
+    (version "0.7.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "ron" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "06iz51r6pyi197jjpfddq8h8884y85myaswfan07cnqylqwkj1w8"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f          ; Cannot find bitflags_serial.
+       #:cargo-inputs
+       (("rust-base64" ,rust-base64-0.13)
+        ("rust-bitflags" ,rust-bitflags-1)
+        ("rust-indexmap" ,rust-indexmap-1)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-option-set" ,rust-option-set-0.1)
+        ("rust-serde-bytes" ,rust-serde-bytes-0.11)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/ron-rs/ron")
+    (synopsis "Rusty Object Notation")
+    (description "This package provides Rusty Object Notation (RON).")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-ron-0.6
   (package
+    (inherit rust-ron-0.7)
     (name "rust-ron")
     (version "0.6.4")
     (source
@@ -49348,18 +49376,13 @@ network services using futures.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "07vzhbrnimz1lij0f280y624j4yzipn2404jmygs24mp7xhshkh6"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-base64" ,rust-base64-0.13)
         ("rust-bitflags" ,rust-bitflags-1)
         ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-serde" ,rust-serde-1))))
-    (home-page "https://github.com/ron-rs/ron")
-    (synopsis "Rusty Object Notation")
-    (description "This package provides Rusty Object Notation (RON).")
-    (license (list license:expat license:asl2.0))))
+        ("rust-serde" ,rust-serde-1))))))
 
 (define-public rust-ron-0.5
   (package