summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-21 17:00:55 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-13 18:19:30 +0100
commit7d1f9c91e67ccdcc0d798b124e0b967177ea6b72 (patch)
tree08c09f2113c8f1a5b79ef8bcc440f37c17b60660 /gnu
parent88002553ae57e8a9b0a3e1af22fc6eaf32d17567 (diff)
downloadguix-7d1f9c91e67ccdcc0d798b124e0b967177ea6b72.tar.gz
gnu: Add perl-test-eol.
* gnu/packages/perl.scm (perl-test-eol): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index a83a896adf..d495fa25aa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7208,6 +7208,30 @@ modified or tested with this API, making it simple to test both individual
 files, as well as to verify that there are no missing or unknown files.")
     (license (package-license perl))))
 
+(define-public perl-test-eol
+  (package
+    (name "perl-test-eol")
+    (version "2.00")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/E/ET/ETHER/Test-EOL-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0l3bxpsw0x7j9nclizcp53mnf9wny25dmg2iglfhzgnk0xfpwzwf"))))
+    (build-system perl-build-system)
+    (home-page
+     "http://search.cpan.org/dist/Test-EOL")
+    (synopsis
+     "Check the correct line endings in your project")
+    (description
+     "@code{Test::EOL} lets you check for the presence of trailing whitespace
+and/or windows line endings in your perl code.")
+    (license perl-license)))
+
 (define-public perl-test-exception
   (package
     (name "perl-test-exception")