summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:43 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:57 +0200
commit7d49984da4347532d5a15ec79edafce5d5a97955 (patch)
tree4e53221567c42fb3f594ae14779c82604b128eed /gnu
parentc548ff6a30705d648e9a704f87001c5090cc8204 (diff)
downloadguix-7d49984da4347532d5a15ec79edafce5d5a97955.tar.gz
gnu: python-pip-run: Don't ask to run tests when cross-compiling.
* gnu/packages/python-xyz.scm
(python-pip-run)[arguments]{#:tests?}: When cross-compiling, set to #false.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a78005e011..e25054da5f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12505,7 +12505,7 @@ $ rm -rf /tmp/env
     (arguments
      (substitute-keyword-arguments (package-arguments python-pip-run-bootstrap)
        ((#:tests? _ #f)
-        #t)
+        (not (%current-target-system)))
        ((#:phases phases #~%standard-phases)
         #~(modify-phases #$phases
             (replace 'check