summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-23 22:12:59 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-25 00:00:32 +0100
commit7dbd73a329d9918711f45c8090a3a92520836211 (patch)
treee878b3706c6d342dbd04b2164eda2faf560aecd6 /gnu
parentdf8b8f0c76388239dac9f2892c97b92e92c92901 (diff)
downloadguix-7dbd73a329d9918711f45c8090a3a92520836211.tar.gz
gnu: python: Remove input labels.
* gnu/packages/python.scm (python-3.9)[native-inputs]: Remove labels.
(python2-minimal)[inputs]: Likewise.
(python-minimal)[inputs]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 0c164d7991..077814719d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
@@ -559,13 +559,13 @@ data types.")
      (modify-inputs (package-inputs python-2.7)
        (replace "openssl" openssl)))
     (native-inputs
-     `(("tzdata" ,tzdata-for-tests)
-       ("unzip" ,unzip)
-       ("zip" ,(@ (gnu packages compression) zip))
-       ,@(if (%current-target-system)
-             `(("python3" ,this-package))
-             '())
-       ,@(package-native-inputs python-2)))
+     (let ((inputs (modify-inputs (package-native-inputs python-2)
+                     (prepend tzdata-for-tests
+                              unzip
+                              (@ (gnu packages compression) zip)))))
+       (if (%current-target-system)
+           (modify-inputs inputs (prepend this-package))
+           inputs)))
     (native-search-paths
      (list (guix-pythonpath-search-path version)
            ;; Used to locate tzdata by the zoneinfo module introduced in
@@ -592,9 +592,7 @@ data types.")
     ;; is invoked upon 'make install'.  'pip' also expects 'ctypes' and thus
     ;; libffi.  Expat is needed for XML support which is expected by a lot
     ;; of libraries out there.
-    (inputs `(("expat" ,expat)
-              ("libffi" ,libffi)
-              ("zlib" ,zlib)))))
+    (inputs (list expat libffi zlib))))
 
 (define-public python-minimal
   (package/inherit python
@@ -605,10 +603,7 @@ data types.")
     ;; OpenSSL is a mandatory dependency of Python 3.x, for urllib;
     ;; zlib is required by 'zipimport', used by pip.  Expat is needed
     ;; for XML support, which is generally expected to be available.
-    (inputs `(("expat" ,expat)
-              ("libffi" ,libffi)
-              ("openssl" ,openssl)
-              ("zlib" ,zlib)))))
+    (inputs (list expat libffi openssl zlib))))
 
 (define-public python-debug
   (package/inherit python