summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2019-09-14 02:15:31 -0400
committerLudovic Courtès <ludo@gnu.org>2019-09-16 10:27:10 +0200
commit7e772cb66d050b86b6dde97bc97d09e708e01714 (patch)
tree25b6c600afc1c7c75ca3fee5794d43a65c7db35a /gnu
parent0074844366381e3056d09492b8b437836c7adb61 (diff)
downloadguix-7e772cb66d050b86b6dde97bc97d09e708e01714.tar.gz
gnu: git-annex: Update license.
* gnu/packages/haskell-apps.scm (git-annex)[license]: Update main license to
AGPLv3+ and include other licenses mentioned in the package's COPYRIGHT file.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-apps.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 5cd6549c27..8c4048aa66 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -374,9 +374,16 @@ unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
 checking the file contents into Git.  It can store files in many places,
 such as local hard drives and cloud storage services.  It can also be
 used to keep a folder in sync between computers.")
-    ;; The web app is released under the AGPLv3+.
-    (license (list license:gpl3+
-                   license:agpl3+))))
+    ;; The main author has released all his changes under AGPLv3+ as of March
+    ;; 2019 (7.20190219-187-g40ecf58d4).  These are also licensed under the
+    ;; original GPLv3+ license, but going forward new changes will be under
+    ;; only AGPLv3+.  The other licenses below cover code written by others.
+    ;; See git-annex's COPYRIGHT file for details on each file.
+    (license (list license:agpl3+
+                   license:gpl3+
+                   license:bsd-2
+                   license:expat
+                   license:gpl2))))
 
 (define-public hlint
   (package