summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-11-03 14:51:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-11-04 11:37:15 +0100
commit7eeab6417f50b35305ec588b9d8e77adaf24f102 (patch)
treecc60d4d525dd0c2aa870103d10d18bd7a3e41565 /gnu
parentf54f36b363a86bb033275e3a0594974d3d91bd53 (diff)
downloadguix-7eeab6417f50b35305ec588b9d8e77adaf24f102.tar.gz
gnu: Add r-methylaid.
* gnu/packages/bioconductor.scm (r-methylaid): New variable.

Change-Id: I7839035e5316bdbe5f1386b7b41ed2fc440fb432
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index b15a856fb9..8ccc5f49b2 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -8637,6 +8637,44 @@ on the basis that cells of the same type should have more similar gene expressio
 profiles than cells of different types.")
     (license license:expat)))
 
+(define-public r-methylaid
+  (package
+    (name "r-methylaid")
+    (version "1.36.0")
+    (source
+    (origin
+      (method url-fetch)
+      (uri (bioconductor-uri "MethylAid" version))
+      (sha256
+        (base32 "0mzml9j6f7yycf9747ikkpfvxnwji07h8jhwa9a54ix2d0wyxk3d"))))
+    (properties `((upstream-name . "MethylAid")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biobase
+           r-biocgenerics
+           r-biocparallel
+           r-ggplot2
+           r-gridbase
+           r-hexbin
+           r-matrixstats
+           r-minfi
+           r-rcolorbrewer
+           r-shiny
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://git.bioconductor.org/packages/MethylAid")
+    (synopsis
+     "Quality control of large Illumina DNA Methylation array data sets")
+    (description
+     "This package provides a visual and interactive web application using
+RStudio's shiny package.  Bad quality samples are detected using sample-dependent
+and sample-independent controls present on the array and user adjustable
+thresholds.  In depth exploration of bad quality samples can be performed using
+several interactive diagnostic plots of the quality control probes present on
+the array.  Furthermore, the impact of any batch effect provided by the user can
+be explored.")
+    (license license:gpl2+)))
+
 (define-public r-methylkit
   (package
     (name "r-methylkit")