summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorgyara <me@gyara.moe>2022-08-29 13:01:55 +0900
committerLudovic Courtès <ludo@gnu.org>2022-09-06 16:58:12 +0200
commit7f939d36dc46000dabe9338587ce2f33866e420a (patch)
tree67f6d524f731ca0483f67725053e82f0346872c9 /gnu
parent8c5065c6d1036012996e4812788e48ca74bc1294 (diff)
downloadguix-7f939d36dc46000dabe9338587ce2f33866e420a.tar.gz
gnu: Add neovim-packer.
* gnu/packages/vim.scm (neovim-packer): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vim.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f19b47c50d..fefdaf8f55 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -639,6 +639,34 @@ various text editors which allow this file format to be read and used by those
 editors.")
     (license license:bsd-2)))
 
+(define-public neovim-packer
+  (let ((commit "3a9f9801f683946b9f1047d8f4bf9946c29e927d")
+        (revision "0"))
+    (package
+      (name "neovim-packer")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/wbthomason/packer.nvim")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1xn08z3a21mgfvp5i1nv57jnldwxwnl5nkryiff3zc99b1mizigp"))))
+      (build-system copy-build-system)
+      (arguments
+       (list #:install-plan
+             #~'(("lua" "share/nvim/site/pack/guix/start/packer.nvim/")
+                 ("doc" "share/nvim/site/pack/guix/start/packer.nvim/"))))
+      (home-page "https://github.com/wbthomason/packer.nvim")
+      (synopsis "Plugin manager for Neovim")
+      (description
+       "This package provides a plugin manager for Neovim, inspired by Emacs's
+@code{use-package}.  It's written in Lua, supports Luarocks dependencies, and
+is based on Vim's builtin plugin support.")
+      (license license:expat))))
+
 (define-public neovim-syntastic
   (package
     (inherit vim-syntastic)