summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-05-12 19:49:01 +0000
committerLudovic Courtès <ludo@gnu.org>2018-06-25 23:34:43 +0200
commit7f996b4ca5ff982cfcd3ba96d5b8577d337e423e (patch)
tree0d1c248da754d39f1b6a2ddc671136adf9e5dbfb /gnu
parent5ecb058c4ee9c9ab350c0f19e90631e21ed42ec7 (diff)
downloadguix-7f996b4ca5ff982cfcd3ba96d5b8577d337e423e.tar.gz
gnu: Add opencl-headers.
* gnu/packages/opencl.scm: New file.
(make-opencl-headers): New function.
(opencl-headers-2.2, opencl-headers-2.1, opencl-headers-2.0,
opencl-headers-1.2, opencl-headers-1.1, opencl-headers-1.0, opencl-headers):
New variables.

* gnu/local.mk: Add the new file.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/opencl.scm82
2 files changed, 83 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9d8947d55d..d579841898 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -322,6 +322,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/ocaml.scm			\
   %D%/packages/ocr.scm				\
   %D%/packages/onc-rpc.scm			\
+  %D%/packages/opencl.scm			\
   %D%/packages/openbox.scm			\
   %D%/packages/openldap.scm			\
   %D%/packages/openstack.scm			\
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
new file mode 100644
index 0000000000..2a21fa6c66
--- /dev/null
+++ b/gnu/packages/opencl.scm
@@ -0,0 +1,82 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages opencl)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix git-download)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:))
+
+;; This file adds OpenCL implementation related packages. Due to the fact that
+;; OpenCL devices are not available during build (store environment), tests are
+;; all disabled.
+;; Check https://lists.gnu.org/archive/html/guix-devel/2018-04/msg00293.html
+
+(define (make-opencl-headers major-version subversion)
+  (let ((commit "e986688daf750633898dfd3994e14a9e618f2aa5")
+        (revision "0"))
+    (package
+      (name "opencl-headers")
+      (version (git-version
+                (string-append major-version "." subversion ".0")
+                revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/KhronosGroup/OpenCL-Headers.git")
+                      (commit commit)))
+                (file-name (string-append name "-" commit))
+                (sha256
+                 (base32
+                  "176ydpbyws5nr4av6hf8p41pkhc0rc4m4vrah9w6gp2fw2i32838"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (delete 'build)
+           (delete 'check)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (copy-recursively (string-append "./opencl" (string-append
+                                                            ,major-version
+                                                            ,subversion) "/CL")
+                                 (string-append
+                                  (assoc-ref outputs "out")
+                                  "/include/CL")))))))
+      (synopsis "The Khronos OpenCL headers")
+      (description
+       "This package provides the C headers by Khronos for OpenCL
+programming.")
+      (home-page "https://www.khronos.org/registry/OpenCL/")
+      (license license:expat))))
+
+(define-public opencl-headers-2.2
+  (make-opencl-headers "2" "2"))
+(define-public opencl-headers-2.1
+  (make-opencl-headers "2" "1"))
+(define-public opencl-headers-2.0
+  (make-opencl-headers "2" "0"))
+(define-public opencl-headers-1.2
+  (make-opencl-headers "1" "2"))
+(define-public opencl-headers-1.1
+  (make-opencl-headers "1" "1"))
+(define-public opencl-headers-1.0
+  (make-opencl-headers "1" "0"))
+
+(define-public opencl-headers opencl-headers-2.2)