summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-18 21:16:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-18 21:16:37 +0100
commit7ffa5de2c7b11bc91e13388b6c0c8106345615ed (patch)
tree9153e5f4cc3d09ff75390034136e2b47616799b8 /gnu
parentc1eb04e6fd1c2cdb30b7b33d500b4ce54cabc27d (diff)
downloadguix-7ffa5de2c7b11bc91e13388b6c0c8106345615ed.tar.gz
gnu: Add axel.
* gnu/packages/networking.scm (axel): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a0f51b701a..ae3f260fef 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -141,6 +141,34 @@
   #:use-module (gnu packages xml)
   #:use-module (ice-9 match))
 
+(define-public axel
+  (package
+    (name "axel")
+    (version "2.17.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/axel-download-accelerator/axel/"
+                           "releases/download/v" version "/"
+                           "axel-" version ".tar.xz"))
+       (sha256
+        (base32 "0m1smb9rmw9w2fcfcf0162qyffx6a1x0j612sg3fydflandlsdpi"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libressl" ,libressl)))
+    (home-page "https://github.com/axel-download-accelerator/axel")
+    (synopsis "Light command line download accelerator")
+    (description
+     "Axel tries to accelerate the download process by using multiple
+connections per file, and can also balance the load between different
+servers.  It tries to be as light as possible, so it might be useful
+on byte-critical systems.  It supports HTTP, HTTPS, FTP and FTPS
+protocols.")
+    (license license:gpl2+)))
+
 ;; This package does not have a release yet.
 ;; But this is required to provide a feature in PipeWire.
 (define-public libcamera