summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 08:43:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:14 +0200
commit81b55b1e77f66b7e47a6d08c8b54a3a31e0dc972 (patch)
treec48d9e29e4e427fa12cec661fb9fff3d50a409e9 /gnu
parent674e93a057ecc79a4f670e48b45d8e910f4f69a3 (diff)
downloadguix-81b55b1e77f66b7e47a6d08c8b54a3a31e0dc972.tar.gz
gnu: Add java-eclipse-equinox-common.
* gnu/packages/java.scm (java-eclipse-equinox-common): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 3d8dd06a02..18c87acd5f 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2368,6 +2368,30 @@ the OSGi Core module.")
 specification.")
     (license license:epl1.0)))
 
+(define-public java-eclipse-equinox-common
+  (package
+    (name "java-eclipse-equinox-common")
+    (version "3.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://repo1.maven.org/maven2/"
+                                  "org/eclipse/platform/org.eclipse.equinox.common/"
+                                  version "/org.eclipse.equinox.common-"
+                                  version "-sources.jar"))
+              (sha256
+               (base32
+                "12aazpkgw46r1qj0pr421jzwhbmsizd97r37krd7njnbrdgfzksc"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests included
+       #:jar-name "eclipse-equinox-common.jar"))
+    (inputs
+     `(("java-eclipse-osgi" ,java-eclipse-osgi)))
+    (home-page "http://www.eclipse.org/equinox/")
+    (synopsis "Common Eclipse runtime")
+    (description "This package provides the common Eclipse runtime.")
+    (license license:epl1.0)))
+
 (define-public java-commons-cli
   (package
     (name "java-commons-cli")