summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-02-01 10:36:01 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-05 06:56:42 +0100
commit81f8cfcf0b52b9928793e5cf8d93d551d771206a (patch)
tree831f4d84142b0a107cd9161ec973e4955ecf862c /gnu
parent44f43603d369d2df06942ecf90f983e850b87f43 (diff)
downloadguix-81f8cfcf0b52b9928793e5cf8d93d551d771206a.tar.gz
gnu: Rename 'libnftnl/fixed' to 'libnftnl/pinned'.
* gnu/packages/linux.scm: Rename variable 'libnftnl/fixed' to
'libnftnl/pinned', add deprecation.
(iptables)[native-inputs]: Replace 'libnftnl/fixed' with 'libnftnl/pinned'.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e105bad406..54e3da8be2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2848,7 +2848,7 @@ external rate conversion.")
     (native-inputs
      (list pkg-config flex bison))
     (inputs
-     (list libmnl libnftnl/fixed))
+     (list libmnl libnftnl/pinned))
     (arguments
      (list #:tests? #f             ; no test suite
            #:configure-flags       ; add $libdir to the RUNPATH of executables
@@ -7654,9 +7654,13 @@ libnftnl has been previously known as libnftables.  This library is currently
 used by nftables.")
     (license license:gpl2+)))
 
+;;; The symbol libnftl/fixed should be used when libnftnl needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias libnftnl/fixed libnftnl/pinned)
+
 ;; This is used in iptables, which contributes to rust.  We're pinning this
 ;; variant to avoid accidental rebuilds of rust.
-(define-public libnftnl/fixed
+(define-public libnftnl/pinned
   (package (inherit libnftnl)
     (version "1.2.0")
     (source