summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authornee <nee.git@cock.li>2016-08-01 19:30:47 +0200
committerLeo Famulari <leo@famulari.name>2016-08-01 20:40:20 -0400
commit826a3ca22c5ed2b39c82bfee32a76c26bdea4223 (patch)
tree626111b789604b121f710a3ac0b2025f6eb814c2 /gnu
parent621954ba4e3e83f5725ebac1809bc47fb525d2dd (diff)
downloadguix-826a3ca22c5ed2b39c82bfee32a76c26bdea4223.tar.gz
gnu: Add supertux.
* gnu/packages/games.scm (supertux): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4db531dc0a..c17d200c3f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2697,3 +2697,37 @@ with the \"Stamp\" tool within Tux Paint.")
     (description
      "Tux Paint Config is a graphical configuration editor for Tux Paint.")
     (license license:gpl2)))            ;no "or later" present
+
+(define-public supertux
+  (package
+   (name "supertux")
+   (version "0.4.0")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "https://github.com/SuperTux/supertux/releases/"
+                                "download/v" version
+                                "/supertux-" version ".tar.bz2"))
+            (sha256
+             (base32
+              "10ppmy6w77lxj8bdzjahc9bidgl4qgzr9rimn15rnqay84ydx3fi"))))
+   (arguments '(#:tests? #f
+                #:configure-flags '("-DINSTALL_SUBDIR_BIN=bin")))
+   (build-system cmake-build-system)
+   (inputs `(("sdl2" ,sdl2)
+             ("sdl2-image" ,sdl2-image)
+             ("sdl2-mixer" ,sdl2-mixer)
+             ("openal" ,openal)
+             ("mesa" ,mesa)
+             ("glew" ,glew)
+             ("libvorbis" ,libvorbis)
+             ("libogg" ,libogg)
+             ("physfs" ,physfs)
+             ("curl" ,curl)
+             ("boost" ,boost)))
+   (native-inputs `(("pkg-config" ,pkg-config)))
+   (synopsis "2D platformer game")
+   (description "SuperTux is a free classic 2D jump'n run sidescroller game
+in a style similar to the original Super Mario games covered under
+the GNU GPL.")
+   (home-page "https://supertuxproject.org/")
+   (license license:gpl3+)))