summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-10-10 20:09:45 +0100
committerChristopher Baines <mail@cbaines.net>2018-03-03 12:51:26 +0000
commit8279b1d3b11ac3e0ad3d94b515695e6d7f2c3511 (patch)
treee8c0807f776da87663daf757cb9b0df2a82a37d9 /gnu
parentb03eb6acb45cf6c0672e309204f5a92ce5fd88ce (diff)
downloadguix-8279b1d3b11ac3e0ad3d94b515695e6d7f2c3511.tar.gz
gnu: Add ruby-mimemagic.
* gnu/packages/ruby.scm (ruby-mimemagic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 47cb8eea8c..3d914d1c46 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3503,6 +3503,33 @@ that TURN is no longer being maintained.")
     (home-page "http://rubygems.org/gems/turn")
     (license license:expat)))
 
+(define-public ruby-mimemagic
+  (package
+    (name "ruby-mimemagic")
+    (version "0.3.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (rubygems-uri "mimemagic" version))
+       (sha256
+        (base32
+         "00ibc1mhvdfyfyl103xwb45621nwyqxf124cni5hyfhag0fn1c3q"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         ;; This phase breaks the tests, as it patches some of the test data.
+         (delete 'patch-source-shebangs))))
+    (native-inputs
+     `(("ruby-bacon" ,ruby-bacon)))
+    (synopsis "Ruby library for MIME detection by extension or content")
+    (description
+     "@acronym{MIME, Multipurpose Internet Mail Extensions} detection by
+extension or content, using the freedesktop.org.xml shared-mime-info
+database.")
+    (home-page "https://github.com/minad/mimemagic")
+    (license license:expat)))
+
 (define-public ruby-mime-types-data
   (package
     (name "ruby-mime-types-data")