summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 15:47:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:35 +0200
commit8285d8a34bc5696eb8c48a74fa4a23ae4727cf83 (patch)
tree0519b7201ae354e591530cebffff25ceeccd5b04 /gnu
parent80f37908331223fd088ec3f9ab86e3fae85604b1 (diff)
downloadguix-8285d8a34bc5696eb8c48a74fa4a23ae4727cf83.tar.gz
gnu: Add texlive-hitszthesis.
* gnu/packages/tex.scm (texlive-hitszthesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 452722a61a..a80e2a1a3d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16462,6 +16462,32 @@ TeX to format a document for nearly-arbitrary values of @code{\\hsize} and
 Technology, ShenZhen).")
     (license license:lppl1.3c)))
 
+(define-public texlive-hitszthesis
+  (package
+    (name "texlive-hitszthesis")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/hitszthesis/"
+                   "doc/latex/hitszthesis/"
+                   "makeindex/hitszthesis/"
+                   "source/latex/hitszthesis/"
+                   "tex/latex/hitszthesis/")
+             (base32
+              "0m1wr3iq1nzcymvnamgna0iiqb3ndllflgawzjjv85aay9jszra0")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hitszthesis")
+    (synopsis
+     "Dissertation template for Harbin Institute of Technology, ShenZhen")
+    (description
+     ;; XXX: Cannot use @acronym and @comma here, because Guile Texinfo does
+     ;; not support this combination.
+     "This package provides a dissertation template for HITSZ (Harbin
+Institute of Technology, ShenZhen), including bachelor, master and doctor
+dissertations.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-hmtrump
   (package
     (name "texlive-hmtrump")