summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 21:20:02 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:17 -0500
commit83664334956965fb440392a4915760e97524792a (patch)
tree77b3d555ee2c0cbcf7606e6c0e33f8445c6dd7d9 /gnu
parenta1d80a04b6c792db83b822a5d77d2b56a2a83149 (diff)
downloadguix-83664334956965fb440392a4915760e97524792a.tar.gz
gnu: xf86-video-tdfx: Update to 1.4.5.
* gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xorg.scm (xf86-video-tdfx): Update to 1.4.5.  Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch26
-rw-r--r--gnu/packages/xorg.scm8
2 files changed, 31 insertions, 3 deletions
diff --git a/gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch b/gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch
new file mode 100644
index 0000000000..05e2154433
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-tdfx-remove-mibstore.patch
@@ -0,0 +1,26 @@
+Removes references to mibstore.h and miInitializeBackingStore, which
+have been removed from xorg-server.  Zack Rusin <zackr@vmware.com>
+wrote: "It was a noop for at least 5 years and it has been removed."
+See: http://patches.openembedded.org/patch/46133/
+
+--- xf86-video-tdfx-1.4.5/src/tdfx_driver.c.~1~	2012-07-17 01:21:16.000000000 -0400
++++ xf86-video-tdfx-1.4.5/src/tdfx_driver.c	2014-12-19 01:36:42.762798424 -0500
+@@ -62,10 +62,6 @@
+ 
+ #include "compiler.h"
+ 
+-/* Drivers using the mi implementation of backing store need: */
+-
+-#include "mibstore.h"
+-
+ /* All drivers using the vgahw module need this */
+ /* This driver needs to be modified to not use vgaHW for multihead operation */
+ #include "vgaHW.h"
+@@ -2373,7 +2369,6 @@
+     }
+   }
+ 
+-  miInitializeBackingStore(pScreen);
+   xf86SetBackingStore(pScreen);
+   xf86SetSilkenMouse(pScreen);
+ 
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 7610268d1d..6eca79935e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2945,17 +2945,19 @@ kernel mode setting (KMS).")
 (define-public xf86-video-tdfx
   (package
     (name "xf86-video-tdfx")
-    (version "1.4.4")
+    (version "1.4.5")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
-               "mirror://xorg/X11R7.7/src/everything/xf86-video-tdfx-"
+               "mirror://xorg/individual/driver/xf86-video-tdfx-"
                version
                ".tar.bz2"))
         (sha256
           (base32
-            "124gsi30rj547jjd7gvv7xykfnwlyrxw0gcacamby7pvl3g33fg0"))))
+           "0nfqf1c8939s21ci1g7gacwzlr4g4nnilahgz7j2bz30zfnzpmbh"))
+        (patches (list
+                  (search-patch "xf86-video-tdfx-remove-mibstore.patch")))))
     (build-system gnu-build-system)
     (inputs `(("mesa" ,mesa)
               ("xf86driproto" ,xf86driproto)