summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-27 23:21:53 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-10 11:47:02 -0500
commit836daaf8f6246e7be72b371f46b19f794cd50a90 (patch)
treed8a18677a710cf2f438e002763f251f88e33e6b0 /gnu
parentb92d09cda1163d4a1a1b449ea3e981e6ca1cf6d6 (diff)
downloadguix-836daaf8f6246e7be72b371f46b19f794cd50a90.tar.gz
gnu: python-pandas: Update to 1.3.5.
* gnu/packages/python-science.scm (python-pandas): Update to 1.3.5.
[phases]{check}: Add a reference to the network accessing tests issue, now
reported upstream.  Reinstate the excelwriter tests.
[propagated-inputs]: Add python-xlsxwriter.
[native-inputs]: Remove python-nose.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm29
1 files changed, 14 insertions, 15 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 1311fbad0c..aa4d5736a7 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
@@ -336,13 +336,13 @@ of the SGP4 satellite tracking algorithm.")
 (define-public python-pandas
   (package
     (name "python-pandas")
-    (version "1.3.4")
+    (version "1.3.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pandas" version))
        (sha256
-        (base32 "1z3gm521wpm3j13rwhlb4f2x0645zvxkgxij37i3imdpy39iiam2"))))
+        (base32 "1wd92ra8xcjgigbypid53gvby89myg68ica6r8hdw4hhvvsqahhy"))))
     (build-system python-build-system)
     (arguments
      `(#:modules ((guix build utils)
@@ -379,23 +379,23 @@ of the SGP4 satellite tracking algorithm.")
                    (invoke "pytest" "-vv" "pandas" "--skip-slow"
                            "--skip-network"
                            "-k"
-                           ;; These tets access the internet:
-                           ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[lxml]
-                           ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[etree]
-                           ;; TODO: the excel tests fail for unknown reasons
-                           (string-append "not test_wrong_url"
-                                          " and not test_excelwriter_fspath"
-                                          " and not test_ExcelWriter_dispatch"
-                                          ;; TODO: Missing input
-                                          " and not TestS3"
-                                          " and not s3"))))))))))
+                           (string-append
+                            ;; These test access the internet (see:
+                            ;; https://github.com/pandas-dev/pandas/issues/45085).:
+                            ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[lxml]
+                            ;; pandas/tests/io/xml/test_xml.py::test_wrong_url[etree]
+                            "not test_wrong_url"
+                            ;; TODO: Missing input
+                            " and not TestS3"
+                            " and not s3"))))))))))
     (propagated-inputs
      (list python-jinja2
            python-numpy
            python-openpyxl
            python-pytz
            python-dateutil
-           python-xlrd))
+           python-xlrd
+           python-xlsxwriter))
     (inputs
      (list which xclip xsel))
     (native-inputs
@@ -403,7 +403,6 @@ of the SGP4 satellite tracking algorithm.")
            python-beautifulsoup4
            python-lxml
            python-html5lib
-           python-nose
            python-pytest
            python-pytest-mock
            ;; Needed to test clipboard support.