summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-03 11:58:51 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-03 11:59:54 +0200
commit83a6ca3c60155479525bbf01e7b9509a994c7d03 (patch)
tree63958b0d95116508723cb09b91863712c585fb65 /gnu
parentbfe513eeb39a3325d1d8a6e23121f7ab4165a874 (diff)
downloadguix-83a6ca3c60155479525bbf01e7b9509a994c7d03.tar.gz
gnu: Add fanc.
* gnu/packages/bioinformatics.scm (fanc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 83ee4ac1df..8d739d4b52 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4655,6 +4655,64 @@ variety of diversity measures including those that make use of phylogenetic
 similarity of community members.")
    (license license:gpl3+)))
 
+(define-public fanc
+  (let ((commit "354401e52ba2320e6b1ba0d3b5aab3541d31c9f3")
+	(revision "1"))
+    (package
+      (name "fanc")
+      (version (git-version "0" revision commit))
+      (source (origin
+		(method git-fetch)
+		(uri (git-reference
+		      (url "https://github.com/vaquerizaslab/fanc.git")
+		      (commit commit)))
+		(file-name (git-file-name name version))
+		(sha256
+		 (base32
+		  "0vp2cak5snla4j2q23d3ixx016bwzvxfiv4z6yp7anl0xaksd5bl"))))
+      (build-system pyproject-build-system)
+      (arguments
+       (list
+        #:test-flags
+        '(list "-m" "not longrunning"
+               ;; XXX: some of the tests here just take forever
+               "--ignore=fanc/test/test_matrix.py")))
+      (propagated-inputs
+       (list python-biopython
+	     python-cooler
+             python-deprecated
+	     python-future
+	     python-genomic-regions
+	     python-gridmap
+	     python-h5py
+	     python-imageio
+	     python-intervaltree
+	     python-matplotlib
+	     python-msgpack
+	     python-msgpack-numpy
+             python-numpy
+	     python-pandas
+	     python-pillow
+	     python-progressbar2
+	     python-pybedtools
+	     python-pybigwig
+	     python-pysam
+	     python-pywavelets
+	     python-pyyaml
+	     python-scikit-image
+	     python-scikit-learn
+	     python-scipy
+	     python-seaborn
+	     python-tables
+	     python-tifffile))
+      (native-inputs
+       (list python-cython python-pytest))
+      (home-page "https://github.com/vaquerizaslab/fanc")
+      (synopsis "Framework for the analysis of C-like data")
+      (description "FAN-C provides a pipeline for analysing Hi-C data starting
+at mapped paired-end sequencing reads.")
+      (license license:gpl3+))))
+
 (define-public fasttree
   (package
    (name "fasttree")