summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-17 22:46:34 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-17 22:59:47 +0200
commit84feaca4888c9916e1a97bb81e5d157673488b70 (patch)
tree8ca63afc8af3e1480662ac97f5a6262cbb5a3ad6 /gnu
parent9d21858e92afb3c7308953b33f8df1642f313a6f (diff)
downloadguix-84feaca4888c9916e1a97bb81e5d157673488b70.tar.gz
gnu: util-linux: Disable tests when building on i586-gnu.
Works around <https://bugs.gnu.org/47791>
Reported by Maxime Devos <maximedevos@telenet.be>.

* gnu/packages/linux.scm (util-linux)[arguments]: Pass #:tests?.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 13253f1ed6..1ea9d80834 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1600,6 +1600,12 @@ providing the system administrator with some help in common tasks.")
                                (string-append "--with-bashcompletiondir="
                                               (assoc-ref %outputs "out")
                                               "/etc/bash_completion.d"))
+
+       ;; FIXME: For now we cannot reliably run tests on GNU/Hurd:
+       ;; <https://bugs.gnu.org/47791>.
+       #:tests? ,(and (not (%current-target-system))
+                      (not (string-suffix? "-gnu" (%current-system))))
+
        #:phases (modify-phases %standard-phases
                   (add-before 'configure 'patch-build-scripts
                     (lambda* (#:key outputs #:allow-other-keys)