summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:48:33 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-27 15:50:20 +0100
commit856c3e08f73b60076670b9bf8a8bf5f0f21012ab (patch)
treeba857e2bffd6b999827f91dd8c67fe546b228033 /gnu
parent88cdba5ccd021a0016c820fb615e29ca91f06c56 (diff)
downloadguix-856c3e08f73b60076670b9bf8a8bf5f0f21012ab.tar.gz
gnu: go-github-com-flynn-archive-go-shlex: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-flynn-archive-go-shlex):
Move from here ...
* gnu/packages/golang-xyz.scm: ... to here.

Change-Id: If6376b45b4d3809ca8452b89c335ca7532ec2759
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
-rw-r--r--gnu/packages/syncthing.scm24
2 files changed, 28 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 487a8fb1e1..5fe66bc67b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1380,6 +1380,34 @@ Alphanum Algorithm} developed by Dave Koelle in Go.")
 defined output to the standard output.")
     (license license:expat)))
 
+;; XXX: This repository has been archived by the owner on Nov 9, 2017. It is
+;; now read-only.
+(define-public go-github-com-flynn-archive-go-shlex
+  (let ((commit "3f9db97f856818214da2e1057f8ad84803971cff")
+        (revision "0"))
+    (package
+      (name "go-github-com-flynn-archive-go-shlex")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/flynn-archive/go-shlex")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1j743lysygkpa2s2gii2xr32j7bxgc15zv4113b0q9jhn676ysia"))))
+      (build-system go-build-system)
+      (arguments
+       (list
+        #:import-path "github.com/flynn-archive/go-shlex"))
+      (synopsis "Go lexer")
+      (description
+       "Shlex is a simple lexer for go that supports shell-style
+quoting, commenting, and escaping.")
+      (home-page "https://github.com/flynn-archive/go-shlex")
+      (license license:asl2.0))))
+
 (define-public go-github-com-gabriel-vasile-mimetype
   (package
     (name "go-github-com-gabriel-vasile-mimetype")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 3cbf413e63..e2ca90cad6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -296,27 +296,3 @@ extensions for the Go language, namely support for record length-delimited
 message streaming.")
     (home-page "https://github.com/matttproud/golang_protobuf_extensions")
     (license asl2.0)))
-
-(define-public go-github-com-flynn-archive-go-shlex
-  (let ((commit "3f9db97f856818214da2e1057f8ad84803971cff")
-        (revision "0"))
-    (package
-      (name "go-github-com-flynn-archive-go-shlex")
-      (version (git-version "0.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                       (url "https://github.com/flynn-archive/go-shlex")
-                       (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1j743lysygkpa2s2gii2xr32j7bxgc15zv4113b0q9jhn676ysia"))))
-      (build-system go-build-system)
-      (arguments
-       '(#:import-path "github.com/flynn-archive/go-shlex"))
-      (synopsis "Go lexer")
-      (description "Shlex is a simple lexer for go that supports shell-style
-quoting, commenting, and escaping.")
-      (home-page "https://github.com/flynn-archive/go-shlex")
-      (license asl2.0))))