summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPradana AUMARS <paumars@courrier.dev>2022-02-27 16:11:03 +0100
committerLudovic Courtès <ludo@gnu.org>2022-03-13 23:26:31 +0100
commit857e5ab22292fe7c2ba5b9855c0829a2ef942d38 (patch)
treeced4d6d79cf9ca8c1050c1baf8e052e899a2f984 /gnu
parent2e5c3d91fea5b583c541d70b4c318c2f81554d43 (diff)
downloadguix-857e5ab22292fe7c2ba5b9855c0829a2ef942d38.tar.gz
gnu: Add python-ansicolors.
* gnu/packages/python-xyz.scm (python-ansicolors): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ea63670d11..7ed6de5a2b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29069,6 +29069,27 @@ static types.")
 async I/O support.")
     (license license:gpl2+)))
 
+(define-public python-ansicolors
+  (package
+    (name "python-ansicolors")
+    (version "1.1.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ansicolors" version ".zip"))
+       (sha256
+        (base32 "1q3jqglkq4z0f6nkkn8bswcwqg012i2grrc27kabr8286dg4zycr"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-tox
+           python-pytest-cov
+           unzip))
+    (home-page "https://github.com/jonathaneunice/colors/")
+    (synopsis "ANSI colors for Python")
+    (description
+     "This package adds ANSI colors and decorations to your strings.")
+    (license license:isc)))
+
 (define-public python-types-ujson
   (package
     (name "python-types-ujson")