summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2021-01-11 16:34:07 +0100
committerLeo Famulari <leo@famulari.name>2021-01-12 17:19:13 -0500
commit85e97c96941a2bd283faa71fdb390ff05632f254 (patch)
tree1fc2f74d19a55a9298932ac9d0f05725f657c0d1 /gnu
parent080d80b6fe27b8631e6f0d8f4d3c9c4d2af1d225 (diff)
downloadguix-85e97c96941a2bd283faa71fdb390ff05632f254.tar.gz
gnu: python-mpd2: Update to 3.0.1.
* gnu/packages/mpd.scm (python-mpd2): Update to 3.0.1.
[arguments]: Use pytest to run the tests.
[native-inputs] Add python-pytest.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mpd.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3b76b5502a..0183dab79c 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -285,20 +285,22 @@ information about tracks being played to a scrobbler, such as Libre.FM.")
 (define-public python-mpd2
   (package
     (name "python-mpd2")
-    (version "0.5.5")
+    (version "3.0.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "python-mpd2" version))
               (sha256
                (base32
-                "0laypd7h1j14b4vrmiayqlzdsh2j5hc3zv4l0fqvbrbw9y6763ii"))))
+                "0fxssbmnv44m03shjyvbqslc69b0160702j2s0flgvdxjggrnbjj"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (invoke "python" "mpd_test.py"))))))
-    (native-inputs `(("python-mock" ,python-mock)))
+           (lambda _ (invoke "python" "-m" "pytest" "mpd/tests.py"))))))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/Mic92/python-mpd2")
     (synopsis "Python MPD client library")
     (description "Python-mpd2 is a Python library which provides a client