summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 14:12:16 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:37 -0500
commit869ff43afd11c01c7d8248d1009ee859501767db (patch)
tree455c598bc4c53ba5c952a6aa2bd567f64636a7e7 /gnu
parent09e02106f24a6547772bb9ae440434a6af9a709a (diff)
downloadguix-869ff43afd11c01c7d8248d1009ee859501767db.tar.gz
gnu: perl-json-maybexs: Move to (gnu packages perl).
* gnu/packages/web.scm (perl-json-maybexs): Move this...
* gnu/packages/perl.scm: To here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm25
-rw-r--r--gnu/packages/web.scm25
2 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 47861821f4..ee27fb9ab3 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1895,6 +1895,31 @@ allowing data to be efficiently communicated between processes.")
 versa using either JSON::XS or JSON::PP.")
     (license (package-license perl))))
 
+(define-public perl-json-maybexs
+  (package
+    (name "perl-json-maybexs")
+    (version "1.003003")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "JSON-MaybeXS-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0q21wzz87drrvblxcm2py8fcvkzwx1hxzfybynz8ln7wv66vbx3f"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-without-module" ,perl-test-without-module)))
+    (inputs
+     `(("perl-cpanel-json-xs" ,perl-cpanel-json-xs)))
+    (home-page "http://search.cpan.org/dist/JSON-MaybeXS")
+    (synopsis "Cpanel::JSON::XS with fallback")
+    (description "This module first checks to see if either Cpanel::JSON::XS
+or JSON::XS is already loaded, in which case it uses that module.  Otherwise
+it tries to load Cpanel::JSON::XS, then JSON::XS, then JSON::PP in order, and
+either uses the first module it finds or throws an error.")
+    (license (package-license perl))))
+
 (define-public perl-json-xs
   (package
     (name "perl-json-xs")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ddaef2b9ec..b3a049f7f6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1401,31 +1401,6 @@ select or poll.")
     (license (package-license perl))
     (home-page "https://github.com/noxxi/p5-io-socket-ssl")))
 
-(define-public perl-json-maybexs
-  (package
-    (name "perl-json-maybexs")
-    (version "1.003003")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
-                           "JSON-MaybeXS-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0q21wzz87drrvblxcm2py8fcvkzwx1hxzfybynz8ln7wv66vbx3f"))))
-    (build-system perl-build-system)
-    (native-inputs
-     `(("perl-test-without-module" ,perl-test-without-module)))
-    (inputs
-     `(("perl-cpanel-json-xs" ,perl-cpanel-json-xs)))
-    (home-page "http://search.cpan.org/dist/JSON-MaybeXS")
-    (synopsis "Cpanel::JSON::XS with fallback")
-    (description "This module first checks to see if either Cpanel::JSON::XS
-or JSON::XS is already loaded, in which case it uses that module.  Otherwise
-it tries to load Cpanel::JSON::XS, then JSON::XS, then JSON::PP in order, and
-either uses the first module it finds or throws an error.")
-    (license (package-license perl))))
-
 (define-public perl-libwww
   (package
     (name "perl-libwww")