summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPier-Hugues Pellerin <phpellerin@gmail.com>2022-03-27 19:45:11 -0400
committerLeo Famulari <leo@famulari.name>2022-03-27 23:11:18 -0400
commit8731ed8eaecd204a87a804ffa235b85c403d943f (patch)
tree8c61820f4c515737375b35deaf5b076c387c168f /gnu
parent2344fb10972a4cefead8e7aa3e0b807da4cf4570 (diff)
downloadguix-8731ed8eaecd204a87a804ffa235b85c403d943f.tar.gz
gnu: Go 1.16: Update to 1.16.15 [security fixes].
Go 1.16.15 (released 2022-03-03) includes a security fix to the regexp/syntax
package[0], as well as bug fixes to the compiler, runtime, the go command, and
the net package. See the Go 1.16.15 milestone[1] on the upstream issue tracker
for details.

[0] CVE-2022-24921 and https://go.dev/issue/51112.
[2] https://github.com/golang/go/issues?q=milestone%3AGo1.16.15+label%3ACherryPickApproved

* gnu/packages/golang.scm (go-1.16): Update to 1.16.15.

Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a8b845e301..027221b15c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -33,6 +33,7 @@
 ;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
 ;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
 ;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
+;;; Copyright © 2022 Pier-Hugues Pellerin <phpellerin@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -466,7 +467,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
   (package
     (inherit go-1.14)
     (name "go")
-    (version "1.16.14")
+    (version "1.16.15")
     (source
      (origin
        (method git-fetch)
@@ -476,7 +477,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "16pn7avzmlw28sldx6yv38a1afdwj7jz3x7kjvlagysqrsh5lwwl"))))
+         "0vlk0r4600ah9fg5apdd93g7i369k0rkzcgn7cs8h6qq2k6hpxjl"))))
     (arguments
      (substitute-keyword-arguments
          (strip-keyword-arguments '(#:tests?) (package-arguments go-1.14))