summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-03 09:51:32 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-03 09:54:57 +0200
commit87bb9c96647d639270e020d235abc09a33396f15 (patch)
tree091806b7edffda4e344fba1f6db2fe35268b54e3 /gnu
parent95b577e09ae4e8a0463dbce23bc6f41e7a01ccce (diff)
downloadguix-87bb9c96647d639270e020d235abc09a33396f15.tar.gz
gnu: zig: Add tuning information.
* gnu/packages/zig.scm (zig-0.9, zig-0.10)[properties]: Add
clang-properties matching input clang packages.

Change-Id: Ib4a665a29e925b85d0e7695810a8889951dd1602
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/zig.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/zig.scm b/gnu/packages/zig.scm
index 853b5766c2..c9c3ddca62 100644
--- a/gnu/packages/zig.scm
+++ b/gnu/packages/zig.scm
@@ -129,7 +129,8 @@ toolchain.  Among other features it provides
     ;; https://github.com/ziglang/zig/issues/6485
     (supported-systems %64bit-supported-systems)
     ;; Stage3 can take a lot of time and isn't verbose.
-    (properties `((max-silent-time . 9600)))
+    (properties `((max-silent-time . 9600)
+                  ,@(clang-properties "13")))
     (license license:expat)))
 
 (define-public zig-0.10
@@ -192,6 +193,8 @@ toolchain.  Among other features it provides
        (replace "lld" lld-15)))
     (native-inputs
      (modify-inputs (package-native-inputs zig-0.9)
-       (replace "llvm" llvm-15)))))
+       (replace "llvm" llvm-15)))
+    (properties `((max-silent-time . 9600)
+                  ,@(clang-properties "15")))))
 
 (define-public zig zig-0.10)