summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-09-06 00:59:03 -0400
committerLudovic Courtès <ludo@gnu.org>2021-09-10 17:30:55 +0200
commit87da4163085b845e4537311b04ff23375d1932de (patch)
tree20ac4862e64e60a2af5a448a896566c9b92ebf5f /gnu
parentfd22921490f40044d58be8ddc3b38b8be12188a6 (diff)
downloadguix-87da4163085b845e4537311b04ff23375d1932de.tar.gz
gnu: racket: suppress build stamp
The `build-stamp` configuration key should generally be set to an empty
string for a release build. The automatically inferred build stamp is
especially unhelpful with Guix, since it ends up being the Unix epoch.

* gnu/packages/racket.scm (racket-minimal)[arguments]: Adjust the
'initialize-config.rktd phase to set 'build-stamp to "".

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/racket.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index 5b3e941e61..661443e0c3 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -217,6 +217,7 @@
                                                    "/lib"))
                                   '("openssl"
                                     "sqlite"))))
+                    (build-stamp . "")
                     (catalogs
                      . (,(string-append
                           "https://download.racket-lang.org/releases/"