summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-12-28 21:39:13 -0500
committerLeo Famulari <leo@famulari.name>2020-12-29 01:28:10 -0500
commit88205d2dea5ffd84cd27262bc5d434f2075abfda (patch)
tree159bcb7f4c7ed85699a4d71a4e433fd939842f81 /gnu
parent8727870ff4e4d5016431985a888f3ca589d81e02 (diff)
downloadguix-88205d2dea5ffd84cd27262bc5d434f2075abfda.tar.gz
gnu: borg: Update to 1.1.15.
* gnu/packages/backup.scm (borg): Update to 1.1.15.
[source]: Update list of Cython-generated files to delete.
[arguments]: Skip another test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 892b92dc2f..64fc23bf4c 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -569,13 +569,13 @@ detection, and lossless compression.")
 (define-public borg
   (package
     (name "borg")
-    (version "1.1.14")
+    (version "1.1.15")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "borgbackup" version))
        (sha256
-        (base32 "1fpdj73cgp96xwasdcifxl7q2pr1my2f4vfdjpv771llri3hgfvx"))
+        (base32 "1g62sdzcw3zx4ccky125ciwnzx6z9kwyvskvp7ijmqxqk3nrxjs9"))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -593,7 +593,8 @@ detection, and lossless compression.")
                        "src/borg/platform/darwin.c"
                        "src/borg/platform/freebsd.c"
                        "src/borg/platform/linux.c"
-                       "src/borg/platform/posix.c"))
+                       "src/borg/platform/posix.c"
+                       "src/borg/platform/syncfilerange.c"))
            ;; Remove bundled shared libraries.
            (with-directory-excursion "src/borg/algorithms"
              (for-each delete-file-recursively
@@ -653,6 +654,7 @@ detection, and lossless compression.")
                         "and not test_access_acl "
                         "and not test_default_acl "
                         "and not test_non_ascii_acl "
+                        "and not test_create_stdin "
                         ;; This test needs the unpackaged pytest-benchmark.
                         "and not benchmark "
                         ;; These tests assume the kernel supports FUSE.