summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-29 15:42:52 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-29 15:42:52 +0200
commit88bd1804a25056591237c4163faeb4e42449244d (patch)
treed9945dace8c47f2592656c5b0983d2c94d1b7632 /gnu
parent88840f02469de4686d5d67f44baa47e436602e27 (diff)
downloadguix-88bd1804a25056591237c4163faeb4e42449244d.tar.gz
gnu: gsl: Move from module algebra to maths.
* gnu/packages/algebra.scm (gsl): Move variable from here...
* gnu/packages/maths.scm (gsl): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm26
-rw-r--r--gnu/packages/maths.scm27
2 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 3a447d8591..b92882a100 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -78,32 +78,6 @@ solve the shortest vector problem.")
    (license lgpl2.1+)
    (home-page "http://perso.ens-lyon.fr/damien.stehle/fplll/")))
 
-(define-public gsl
-  (package
-    (name "gsl")
-    (version "1.15")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/gsl/gsl-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "18qf6jzz1r3mzb5qynywv4xx3z9g61hgkbpkdrhbgqh2g7jhgfc5"))))
-    (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/gsl/")
-    (synopsis "Numerical library for C and C++")
-    (description
-     "The GNU Scientific Library (GSL) is a numerical library for C
-and C++ programmers.  It is free software under the GNU General
-Public License.
-
-The library provides a wide range of mathematical routines such
-as random number generators, special functions and least-squares
-fitting.  There are over 1000 functions in total with an
-extensive test suite.")
-    (license gpl3+)))
-
 (define-public pari-gp
   (package
    (name "pari-gp")
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 7b900225b5..a2bb2a450e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -23,7 +23,6 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
-  #:use-module (gnu packages algebra)
   #:use-module (gnu packages compression)
   #:use-module ((gnu packages gettext)
                 #:renamer (symbol-prefix-proc 'gnu:))
@@ -67,6 +66,32 @@ the standard data file.")
    (license license:gpl3+)
    (home-page "http://www.gnu.org/software/units/")))
 
+(define-public gsl
+  (package
+    (name "gsl")
+    (version "1.15")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/gsl/gsl-"
+                          version ".tar.gz"))
+      (sha256
+       (base32
+        "18qf6jzz1r3mzb5qynywv4xx3z9g61hgkbpkdrhbgqh2g7jhgfc5"))))
+    (build-system gnu-build-system)
+    (home-page "http://www.gnu.org/software/gsl/")
+    (synopsis "Numerical library for C and C++")
+    (description
+     "The GNU Scientific Library (GSL) is a numerical library for C
+and C++ programmers.  It is free software under the GNU General
+Public License.
+
+The library provides a wide range of mathematical routines such
+as random number generators, special functions and least-squares
+fitting.  There are over 1000 functions in total with an
+extensive test suite.")
+    (license license:gpl3+)))
+
 (define-public pspp
   (package
     (name "pspp")