summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorkiasoc5 <kiasoc5@tutanota.com>2022-01-26 22:43:44 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-28 09:42:34 +0100
commit88eb611c106d9a76b3905ae30e4a56c45c369683 (patch)
tree6d9cf6e939450fd2dd5d598e06ffaf2269bed218 /gnu
parent51199431e7fdf381165c6672f92cfb9025cb13c7 (diff)
downloadguix-88eb611c106d9a76b3905ae30e4a56c45c369683.tar.gz
gnu: httpie: Update to 3.0.2.
* gnu/packages/python-web.scm (httpie): Update to 3.0.2.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 406c6cb51b..6a3fc27353 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -741,21 +741,27 @@ other HTTP libraries.")
 (define-public httpie
   (package
     (name "httpie")
-    (version "2.3.0")
+    (version "3.0.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "httpie" version))
        (sha256
         (base32
-         "15ngl3yc186gkgqdx8iav9bpj8gxjpzz26y32z92jwyhj4cmfh6m"))))
+         "16ay8mx2v1z3rywsszy055l5k50qjiwyc3pds5wxxzd1n9a79w97"))))
     (build-system python-build-system)
     (arguments
      ;; The tests attempt to access external web servers, so we cannot run them.
      '(#:tests? #f))
     (propagated-inputs
-     (list python-colorama python-pygments python-requests
-           python-requests-toolbelt))
+     (list python-colorama
+           python-pygments
+           python-requests
+           python-requests-toolbelt
+           python-pysocks
+           python-charset-normalizer
+           python-defusedxml
+           python-multidict))
     (home-page "https://httpie.io")
     (synopsis "cURL-like tool for humans")
     (description