summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-28 15:31:30 -0500
committerMark H Weaver <mhw@netris.org>2015-01-28 15:43:33 -0500
commit893046ff4ba030bc652e7dbd088c333db10ea09b (patch)
tree683907001931a106dd915332da792c1807dcc51a /gnu
parentd3206af65a7fc12f529f656417bce955434fffca (diff)
downloadguix-893046ff4ba030bc652e7dbd088c333db10ea09b.tar.gz
gnu: Remove 'xf86-video-ast' and 'xf86-video-newport' drivers.
* gnu/packages/xorg.scm (xf86-video-ast, xf86-video-newport): Comment out.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm93
1 files changed, 48 insertions, 45 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 72a86aa85d..fe269c6baf 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -2379,29 +2379,30 @@ devices, thus making direct access unnecessary.")
     (description "X.org provides an implementation of the X Window System")
     (license license:x11)))
 
-
-(define-public xf86-video-ast
-  (package
-    (name "xf86-video-ast")
-    (version "0.93.10")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "mirror://xorg/individual/driver/xf86-video-ast-"
-               version
-               ".tar.bz2"))
-        (sha256
-          (base32
-           "1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))
-        (patches (list (search-patch "xf86-video-ast-remove-mibstore.patch")))))
-    (build-system gnu-build-system)
-    (inputs `(("xorg-server" ,xorg-server)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (home-page "http://www.x.org/wiki/")
-    (synopsis "Xorg implementation of the X Window System")
-    (description "X.org provides an implementation of the X Window System")
-    (license license:x11)))
+;; This driver depends on XAA which has been removed from xorg-server.
+;;
+;; (define-public xf86-video-ast
+;;   (package
+;;     (name "xf86-video-ast")
+;;     (version "0.93.10")
+;;     (source
+;;       (origin
+;;         (method url-fetch)
+;;         (uri (string-append
+;;                "mirror://xorg/individual/driver/xf86-video-ast-"
+;;                version
+;;                ".tar.bz2"))
+;;         (sha256
+;;           (base32
+;;            "1q64z8qqa0ix3cymqiwk1s3sphd1fvvz30lvyxhgkgciygz6dm69"))
+;;         (patches (list (search-patch "xf86-video-ast-remove-mibstore.patch")))))
+;;     (build-system gnu-build-system)
+;;     (inputs `(("xorg-server" ,xorg-server)))
+;;     (native-inputs `(("pkg-config" ,pkg-config)))
+;;     (home-page "http://www.x.org/wiki/")
+;;     (synopsis "Xorg implementation of the X Window System")
+;;     (description "X.org provides an implementation of the X Window System")
+;;     (license license:x11)))
 
 
 (define-public xf86-video-ati
@@ -2712,27 +2713,29 @@ kernel mode setting (KMS).")
     (license license:x11)))
 
 
-(define-public xf86-video-newport
-  (package
-    (name "xf86-video-newport")
-    (version "0.2.4")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (string-append
-               "mirror://xorg/individual/driver/xf86-video-newport-"
-               version
-               ".tar.bz2"))
-        (sha256
-          (base32
-            "1yafmp23jrfdmc094i6a4dsizapsc9v0pl65cpc8w1kvn7343k4i"))))
-    (build-system gnu-build-system)
-    (inputs `(("xorg-server" ,xorg-server)))
-    (native-inputs `(("pkg-config" ,pkg-config)))
-    (home-page "http://www.x.org/wiki/")
-    (synopsis "Xorg implementation of the X Window System")
-    (description "X.org provides an implementation of the X Window System")
-    (license license:x11)))
+;; This driver depends on XAA which has been removed from xorg-server.
+;;
+;; (define-public xf86-video-newport
+;;   (package
+;;     (name "xf86-video-newport")
+;;     (version "0.2.4")
+;;     (source
+;;       (origin
+;;         (method url-fetch)
+;;         (uri (string-append
+;;                "mirror://xorg/individual/driver/xf86-video-newport-"
+;;                version
+;;                ".tar.bz2"))
+;;         (sha256
+;;           (base32
+;;             "1yafmp23jrfdmc094i6a4dsizapsc9v0pl65cpc8w1kvn7343k4i"))))
+;;     (build-system gnu-build-system)
+;;     (inputs `(("xorg-server" ,xorg-server)))
+;;     (native-inputs `(("pkg-config" ,pkg-config)))
+;;     (home-page "http://www.x.org/wiki/")
+;;     (synopsis "Xorg implementation of the X Window System")
+;;     (description "X.org provides an implementation of the X Window System")
+;;     (license license:x11)))
 
 
 (define-public xf86-video-nv