summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJesse Gibbons <jgibbons2357+guix@gmail.com>2020-07-20 20:35:09 -0600
committerEfraim Flashner <efraim@flashner.co.il>2020-09-05 22:50:56 +0300
commit89b091a65f15bc9a638ddf1414b2ce3a1648e4af (patch)
tree102ed878e71732b7909d3a9340641dc8a01904d6 /gnu
parentda09b47b947e2ea4a8ed22b4755e2221d4e27f36 (diff)
downloadguix-89b091a65f15bc9a638ddf1414b2ce3a1648e4af.tar.gz
gnu: Add npiet.
* gnu/packages/piet.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/piet.scm70
2 files changed, 71 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b059dedfe3..dd15126b26 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -430,6 +430,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/photo.scm			\
   %D%/packages/phabricator.scm 			\
   %D%/packages/php.scm				\
+  %D%/packages/piet.scm			\
   %D%/packages/pkg-config.scm			\
   %D%/packages/plotutils.scm			\
   %D%/packages/poedit.scm				\
diff --git a/gnu/packages/piet.scm b/gnu/packages/piet.scm
new file mode 100644
index 0000000000..5282290456
--- /dev/null
+++ b/gnu/packages/piet.scm
@@ -0,0 +1,70 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357+guix@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages piet)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages gd)
+  #:use-module (gnu packages groff)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages tcl))
+
+(define-public npiet
+  (package
+    (name "npiet")
+    (version "1.3f")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.bertnase.de/npiet/npiet-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0nl59fhdqqr7nslxdirdn8nvlq5wws67c7jyx2ckbmxbc9h8bv9d"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-binaries
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (wrap-program (string-append out "/bin/npietedit")
+                 `("PATH" ":" prefix (,(dirname (which "wish")))))
+               #t))))))
+    (inputs
+     `(("gd" ,gd)
+       ("giflib" ,giflib)
+       ("libpng" ,libpng)
+       ("tk" ,tk)))
+    (native-inputs `(("groff" ,groff)))
+    (synopsis "Piet interpreter")
+    (description
+     "Npiet is an interpreter for the piet programming language.  Instead of
+text, piet programs are pictures.  Commands are determined based on changes in
+color.
+
+This package includes:
+@enumerate
+@item npiet, a piet interpreter with debugging capabilities
+@item npiet-foogol, a program that builds a piet program from foogol, an
+algol-like language
+@item npietedit, an editor for the piet programming language
+@end enumerate")
+    (home-page "https://www.bertnase.de/npiet/")
+    (license license:gpl2+)))