summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-08-05 12:09:58 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-09-17 11:03:46 +1000
commit89c3eaaa983e741b93544d6e67ae2123cba03616 (patch)
tree5d93e048b2f4ff729ea2ac7b566be82c92dfa0ac /gnu
parent5d20e1ecafe54e417ea58bc668cfd1ca89ca2dcd (diff)
downloadguix-89c3eaaa983e741b93544d6e67ae2123cba03616.tar.gz
gnu: Add python-pendulum.
* gnu/packages/time.scm (python-pendulum): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/time.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index e2852297c4..4d3da87174 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -82,3 +82,33 @@ to a file.")
 
 (define-public python2-tzdata
   (package-with-python2 python-pytzdata))
+
+(define-public python-pendulum
+  (package
+    (name "python-pendulum")
+    (version "1.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pendulum" version))
+       (sha256
+        (base32
+         "1fj36yxi2f4lzchzd8ny1qjl67dbypnk0gn8qwad2w78579m8m8z"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-nose" ,python-nose)))
+    (propagated-inputs
+     `(("python-dateutil" ,python-dateutil)
+       ("python-pytzdata" ,python-pytzdata)
+       ("python-tzlocal" ,python-tzlocal)))
+    (home-page "https://github.com/sdispater/pendulum")
+    (synopsis "Alternate API for Python datetimes")
+    (description "Pendulum is a drop-in replacement for the standard
+@{datetime} class, providing an alternative API.  As it inherits from the
+standard @code{datetime} all @code{datetime} instances can be replaced by
+Pendulum instances.")
+    (license expat)))
+
+(define-public python2-pendulum
+  (package-with-python2 python-pendulum))