summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2019-02-07 14:44:44 +0100
committerRutger Helling <rhelling@mykolab.com>2019-02-07 14:45:54 +0100
commit89ea6252b6849131ba35d141006e1bbf3a49594f (patch)
treee3e72d40b85b83239267d6dd5cae996f9c3fece9 /gnu
parenta9ba0a3154f3f20097000407a96a390ad3dee100 (diff)
downloadguix-89ea6252b6849131ba35d141006e1bbf3a49594f.tar.gz
gnu: flatpak: Update to 1.2.0.
* gnu/packages/package-management.scm (flatpak): Update to 1.2.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c52f5e3699..c3b195a64f 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -961,7 +961,7 @@ the bootloader configuration.")
 (define-public flatpak
   (package
    (name "flatpak")
-   (version "1.1.0")
+   (version "1.2.0")
    (source
     (origin
      (method url-fetch)
@@ -969,7 +969,7 @@ the bootloader configuration.")
                          version "/flatpak-" version ".tar.xz"))
      (sha256
       (base32
-       "0bkjwh49kajyd78vdh0g9arb352a7rccaifas9zxa78phhja2v2p"))))
+       "1bdk6qmsvy4d80245x1si9qvrga2f2yalj9qfmf1lqj5ljxxxifv"))))
    (build-system gnu-build-system)
    (arguments
     '(#:tests? #f ;; Tests fail due to trying to create files where it can't.
@@ -988,6 +988,7 @@ the bootloader configuration.")
                     ("pkg-config" ,pkg-config)))
    (inputs `(("appstream-glib" ,appstream-glib)
              ("bubblewrap" ,bubblewrap)
+             ("dconf" ,dconf)
              ("gdk-pixbuf" ,gdk-pixbuf)
              ("gpgme" ,gpgme)
              ("json-glib" ,json-glib)