summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-19 09:19:09 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-19 09:19:09 +0800
commit8a0263f17b9c754f6de7ee0b869249e87bfb7e3f (patch)
treef525f7b03fbdd0622a6c1705ca42e08eaa4eb0ff /gnu
parent9523f6378ab87067ef65e30965e9b3c6392f3c9e (diff)
downloadguix-8a0263f17b9c754f6de7ee0b869249e87bfb7e3f.tar.gz
gnu: tk: Build with Xft support.
* gnu/packages/tcl.scm (tk)[inputs]: Add LIBXFT.
  [native-inputs]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tcl.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index 7c2c3e549b..afa715c4cb 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -154,8 +154,9 @@ X11 GUIs.")
 
        ;; The tests require a running X server, so we just skip them.
        #:tests? #f))
-    (inputs `(("tcl" ,tcl)))
-
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("libxft" ,libxft)
+              ("tcl" ,tcl)))
     ;; tk.h refers to X11 headers, hence the propagation.
     (propagated-inputs `(("libx11" ,libx11)
                          ("libxext" ,libxext)))