summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-24 18:23:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-24 18:38:31 +0200
commit8ae0558aad343a033edd0222cb373ea772cb3b3f (patch)
treed66f2b17394d33015ac68210d817d22eb56c1244 /gnu
parentb6cd89084dc51c48f19d779075306bb143659cfd (diff)
downloadguix-8ae0558aad343a033edd0222cb373ea772cb3b3f.tar.gz
gnu: Add perl-sort-naturally.
* gnu/packages/perl.scm (perl-sort-naturally): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3c92b17563..357deb37c6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6320,6 +6320,27 @@ compact.")
 arrays by one or multiple calculated keys.")
     (license (package-license perl))))
 
+(define-public perl-sort-naturally
+  (package
+    (name "perl-sort-naturally")
+    (version "1.03")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/B/BI/BINGOS/Sort-Naturally-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0ip7q5g8d3lr7ri3ffcbrpk1hzzsiwgsn14k10k7hnjphxf1raza"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Sort-Naturally/")
+    (synopsis "Sort lexically, but sort numeral parts numerically")
+    (description "This module exports two functions, @code{nsort} and
+@code{ncmp}; they are used in implementing a \"natural sorting\" algorithm.
+Under natural sorting, numeric substrings are compared numerically, and other
+word-characters are compared lexically.")
+    (license (package-license perl))))
+
 (define-public perl-specio
   (package
     (name "perl-specio")