summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:15 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:27 +0200
commit8b1810bf31973d105d6f770ef8f2d7c16d8a9f2a (patch)
treeeeb481e4c6675cab1b0e8bdbc3c11aba8e407b64 /gnu
parent9987be26929eff44c46794555242fdf665e4f819 (diff)
downloadguix-8b1810bf31973d105d6f770ef8f2d7c16d8a9f2a.tar.gz
gnu: Add trytond-carrier.
* gnu/packages/tryton.scm (trytond-carrier): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index addaea9fdb..c42d34b41e 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -1457,6 +1457,30 @@ configuration file.")
 and account.")
     (license license:gpl3+)))
 
+(define-public trytond-carrier
+  (package
+    (name "trytond-carrier")
+    (version "6.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_carrier" version))
+       (sha256
+        (base32 "0kp08jb5f86bzfyn99qs4k1047svdrkhz3jxv3jw46vrpc2s0c1y"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "carrier"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-country" ,trytond-country)
+       ("trytond-party" ,trytond-party)
+       ("trytond-product" ,trytond-product)))
+    (home-page "https://docs.tryton.org/projects/modules-carrier")
+    (synopsis "Tryton module with carriers")
+    (description "The @emph{Carrier} Tryton module defines the concept
+of carrier.")
+    (license license:gpl3+)))
+
 (define-public trytond-company
   (package
     (name "trytond-company")