summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-23 19:30:52 +0100
committerJulien Lepiller <julien@lepiller.eu>2024-01-01 10:36:51 +0100
commit8ba7a4a042cf04923ca1c686980efc170e9db086 (patch)
tree91777bdf72e433c010b6590efe83a8ce07f6ae93 /gnu
parent3bb1390171fe71ce8786648a5d8e2b4ed142e4ea (diff)
downloadguix-8ba7a4a042cf04923ca1c686980efc170e9db086.tar.gz
gnu: Add java-jakarta-annotations-api.
* gnu/packages/java.scm (java-jakarta-annotations-api): New variable.

Change-Id: I374d1be6f1c509c9c6391e0551de5362eae13357
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d73550c042..e2c2a041a9 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -13719,6 +13719,34 @@ Processing specification.")
     ;; with classpath exception
     (license license:epl2.0)))
 
+(define-public java-jakarta-annotations-api
+  (package
+    (name "java-jakarta-annotations-api")
+    (version "2.1.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/jakartaee/common-annotations-api")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xq2n2pijal5p75vl9dz10i6hhdmaxw5q8j3aza717xkpxxby9p6"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "jakarta-annotations-api.jar"
+       #:source-dir "api/src/main/java"
+       #:tests? #f; no tests
+       #:jdk ,openjdk11))
+    (home-page "https://github.com/jakartaee/common-annotations-api")
+    (synopsis "Collection of Java annotations")
+    (description "Jakarta Annotations defines a collection of annotations
+representing common semantic concepts that enable a declarative style of
+programming that applies across a variety of Java technologies.")
+    ;; with classpath exception
+    (license (list license:epl2.0
+                   license:gpl2))))
+
 (define-public java-xmp
   (package
     (name "java-xmp")