summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-02 15:43:11 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-02 17:58:02 +0200
commit8c78aeb72436ff4b152cfd29f593753e2e759b75 (patch)
treedbcb825bc96743582c37df701df1966f2f467ee7 /gnu
parentd03781c3bc6cbdec721fdd9752feae6556009000 (diff)
downloadguix-8c78aeb72436ff4b152cfd29f593753e2e759b75.tar.gz
gnu: openssl: Move static libraries to "static" output.
* gnu/packages/tls.scm (openssl)[outputs]: New field.
[arguments]: Add 'move-static-libraries' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d013cdf4b5..08c869bc30 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -211,6 +211,8 @@ required structures.")
              (patches (search-patches "openssl-runpath.patch"
                                       "openssl-c-rehash-in.patch"))))
    (build-system gnu-build-system)
+   (outputs '("out"
+              "static"))                          ;6MiB of .a files
    (native-inputs `(("perl" ,perl)))
    (arguments
     `(#:disallowed-references (,perl)
@@ -267,6 +269,19 @@ required structures.")
                        (find-files (string-append out "/lib")
                                    "\\.so"))
              #t)))
+        (add-after 'install 'move-static-libraries
+          (lambda* (#:key outputs #:allow-other-keys)
+            ;; Move static libraries to the "static" output.
+            (let* ((out    (assoc-ref outputs "out"))
+                   (lib    (string-append out "/lib"))
+                   (static (assoc-ref outputs "static"))
+                   (slib   (string-append static "/lib")))
+              (mkdir-p slib)
+              (for-each (lambda (file)
+                          (install-file file slib)
+                          (delete-file file))
+                        (find-files lib "\\.a$"))
+              #t)))
         (add-before
          'patch-source-shebangs 'patch-tests
          (lambda* (#:key inputs native-inputs #:allow-other-keys)