summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 23:34:12 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 23:53:38 +0000
commit8cab6bac1c6314d210b8cfaccf650bbced1f01aa (patch)
tree90eb8465302268fe24217f2d1c9ceda4a2f8f0df /gnu
parent4da2f179d27420975bfb976e5aa4d11d365a9a2a (diff)
downloadguix-8cab6bac1c6314d210b8cfaccf650bbced1f01aa.tar.gz
gnu: python-simpervisor: Update to 1.0.0.
* gnu/packages/python-xyz.scm (python-simpervisor): Update to 1.0.0.
[build-system]: Swap to pyproject-build-system, new release does not
have setup.py.
[native-inputs]: Add python-hatchling.

Change-Id: I3c0c9d4e22b5462af11bed2f823e4dbefd291180
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 70bfdb60a3..1a804f165b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31148,7 +31148,7 @@ module patches @code{asyncio} to allow nested use of @code{asyncio.run} and
 (define-public python-simpervisor
   (package
     (name "python-simpervisor")
-    (version "0.4")
+    (version "1.0.0")
     (source
       (origin
         ;; Tests not included in release.
@@ -31158,8 +31158,8 @@ module patches @code{asyncio} to allow nested use of @code{asyncio.run} and
                (commit (string-append "v" version))))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "1brsisx7saf4ic0dih1n5y7rbdbwn1ywv9pl32bch3061r46prvv"))))
-    (build-system python-build-system)
+         (base32 "0drvqxbr6fpydb4d7z5dhn97d578gf39sd8cawyl6ksf1f4y8yzg"))))
+    (build-system pyproject-build-system)
     (arguments
      `(#:tests? #f  ; Test suite can't find aiohttp.
        #:phases
@@ -31171,7 +31171,10 @@ module patches @code{asyncio} to allow nested use of @code{asyncio.run} and
                (invoke "pytest" "--maxfail" "3" "--verbose"))
              #t)))))
     (native-inputs
-     (list python-aiohttp python-pytest python-pytest-asyncio))
+     (list python-aiohttp
+           python-hatchling
+           python-pytest
+           python-pytest-asyncio))
     (home-page "https://github.com/yuvipanda/simpervisor")
     (synopsis "Simple async process supervisor")
     (description