summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2022-02-01 18:14:24 +1100
committerMarius Bakke <marius@gnu.org>2022-09-01 16:08:15 +0200
commit8e6af98fbb3119fd01d2feb2d721b4b5f0f2bc01 (patch)
tree1a3fda294d172836be789e8146c9cf101eb0d93f /gnu
parent98bc5e77aff36fb787803f32c65b7f7936baf345 (diff)
downloadguix-8e6af98fbb3119fd01d2feb2d721b4b5f0f2bc01.tar.gz
gnu: libdbusmenu-qt: Move to (gnu packages qt).
*  gnu/packages/lxqt.scm: Remove libdbusmenu-qt.
*  gnu/packages/qt.scm: Re-add libdbusmenu-qt.

Signed-off-by: Marius Bakke <marius@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lxqt.scm32
-rw-r--r--gnu/packages/qt.scm32
2 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index ceb69f2199..606b483d3e 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -10,7 +10,7 @@
 ;;; Copyright © 2019, 2020 Reza Alizadeh Majd <r.majd@pantherx.org>
 ;;; Copyright © 2020 Fakhri Sajadi <f.sajadi@pantherx.org>
 ;;; Copyright © 2020 André Batista <nandre@riseup.net>
-;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -69,36 +69,6 @@
 
 ;; Third party libraries
 
-(define-public libdbusmenu-qt
-  (package
-    (name "libdbusmenu-qt")
-    (version "0.9.3+16.04.20160218-0ubuntu1")
-    (source
-     (origin
-       (method git-fetch)
-       ;; Download from github rather than launchpad because launchpad trunk
-       ;; tarball hash is not deterministic.
-       (uri (git-reference
-             (url "https://github.com/unity8-team/libdbusmenu-qt")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0b7ii1cvmpcyl79gqal9c3va9m55h055s4hx7fpxkhhqs9463ggg"))))
-    (build-system cmake-build-system)
-    (arguments
-     ;; XXX: Tests require a dbus session and some icons.
-     '(#:tests? #f))
-    (native-inputs
-     (list doxygen))
-    (inputs
-     (list qtbase-5))
-    (home-page "https://launchpad.net/libdbusmenu-qt")
-    (synopsis "Qt implementation of the DBusMenu spec")
-    (description "This library provides a Qt implementation of the DBusMenu
-protocol.  The DBusMenu protocol makes it possible for applications to export
-and import their menus over DBus.")
-    (license license:lgpl2.1+)))
-
 (define-public libstatgrab
   (package
     (name "libstatgrab")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 53166980e8..f0c5aa312d 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -20,7 +20,7 @@
 ;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
@@ -4061,3 +4061,33 @@ data.")
 also compatible with SGI and TGS Open Inventor, and the API is based on the API
 of the InventorXt GUI component toolkit.")
     (license license:bsd-3))))
+
+(define-public libdbusmenu-qt
+  (package
+    (name "libdbusmenu-qt")
+    (version "0.9.3+16.04.20160218-0ubuntu1")
+    (source
+     (origin
+       (method git-fetch)
+       ;; Download from github rather than launchpad because launchpad trunk
+       ;; tarball hash is not deterministic.
+       (uri (git-reference
+             (url "https://github.com/unity8-team/libdbusmenu-qt")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0b7ii1cvmpcyl79gqal9c3va9m55h055s4hx7fpxkhhqs9463ggg"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; XXX: Tests require a dbus session and some icons.
+     '(#:tests? #f))
+    (native-inputs
+     (list doxygen))
+    (inputs
+     (list qtbase-5))
+    (home-page "https://launchpad.net/libdbusmenu-qt")
+    (synopsis "Qt implementation of the DBusMenu spec")
+    (description "This library provides a Qt implementation of the DBusMenu
+protocol.  The DBusMenu protocol makes it possible for applications to export
+and import their menus over DBus.")
+    (license license:lgpl2.1+)))